摘要:最近接触到h3c的交换机,这里记录一下常见的用法。貌似国产交换机比如华为交换机都差不多算是一派,然后国外的比如思科的算是一派。

常见用法

开启接口的三层路由

[H3C] interface g1/0/1
[H3C-GigabitEthernet1/0/1] port link-mode route //开启该接口的三层路由功能
[H3C-GigabitEthernet1/0/1] port link-mode bridge //关闭该接口的三层路由功能
端口分为Route口和Bridge口 Route口为三层口,可端口下直接配置IP。
Bridge口为二层口,端口可配置端口类型为Trunk、Access、hybrid等,不可直接配置IP。二层接口,默认是access接口。

vlan操作

创建vlan100并将端口加入vlan100

创建vlan100,并将1/0/1口加入vlan100
<DeviceA> system-view
//创建vlan100
[DeviceA] vlan 100 
//将port gigabitethernet 1/0/1加入vlan 100
[DeviceA-vlan100] port gigabitethernet 1/0/1
//退出
[DeviceA-vlan100] quit

查看vlan100的详细信息

display vlan 100

关闭vlan

undo vlan 100

vlan的虚拟接口操作

配置vlan100的虚拟接口

给vlan100创建一个虚拟接口
interface Vlan-interface 100 //给vlan 100创建一个虚拟接口
ip address 192.168.1.1 24 //配置其IP地址为192.168.1.1/24

其实虚拟接口可以配一个主ip地址和配一个从ip地址。参考:IP地址典型配置举例

关闭vlan100的虚拟接口

//第一种方法
no interface vlan 100 //关闭vlan100的虚拟接口
//第二种方法
interface vlan-interface 100
shutdown

打开vlan100的虚拟接口

interface vlan-interface 100
undo shutdown

查看vlan100虚拟接口的详细信息

// 简要查看vlan100的虚拟接口的信息
display interface Vlan-interface 100 brief
// 详细查看vlan100的虚拟接口的信息
display interface Vlan-interface 100

端口操作

开启一个端口并将端口加入vlan100

// 将端口GigabitEthernet1/0/1设置为access并加入vlan100
// interface GigabitEthernet 1/0/1 (这是光口一般是千兆的) 
// 电口一般是:interface Ethernet 1/0/1 
int GigabitEthernet1/0/1
//打开端口
undo shutdown
//缺省情况下,端口的链路类型为Access
port link-type access
//将端口加入vlan100
port access vlan 100

关闭端口

int GigabitEthernet1/0/1
//关闭端口
shutdown

设置端口为trunk以及设置端口的默认vlan

[H3C] int GigabitEthernet1/0/1

//缺省情况下,端口的链路类型为Access类型。
//将GigabitEthernet1/0/1设置为trunk
[H3C-GigabitEthernet1/0/1] port link-type trunk

//允许指定的VLAN通过当前Trunk端口
//缺省情况下,Trunk端口只允许VLAN 1的报文通过
[H3C-GigabitEthernet1/0/1] port trunk permit vlan { vlan-id-list | all }

//(可选)设置Trunk端口的缺省VLAN
// 缺省情况下,Trunk端口的缺省VLAN为VLAN 1
[H3C-GigabitEthernet1/0/1]  port trunk pvid vlan vlan-id

查看端口的详细信息

方法一:

display current-configuration interface g1/0/1 # 查看g1/0/1端口的详细信息

方法二:

# 查看g1/0/1端口的详细信息
int g1/0/1
display this

静态链路聚合的典型配置

创建二层聚合端口

[H3C-A] interface Bridge-Aggregation 1  
[H3C-A-Bridge-Aggregation1] port link-type trunk
[H3C-A-Bridge-Aggregation1] port trunk permit vlan 10 20 30

分别将设备A上聚合端口加入到聚合组中

[H3C-A] interface Ethernet 1/0/1
[H3C-A-Ethernet1/0/1] port link-type trunk
[H3C-A-Ethernet1/0/1] port trunk permit vlan 10 20 30
[H3C-A-Ethernet1/0/1] port link-aggregation group 1

查看链路聚合命令

[H3C] display link-aggregation verbose

动态聚合模式

创建二层聚合端口

[H3C-A] interface Bridge-Aggregation 1  
[H3C-A-Bridge-Aggregation1] port link-type trunk
[H3C-A-Bridge-Aggregation1] port trunk permit vlan 10 20 30
[H3C-A-Bridge-Aggregation1] link-aggreation mode dynamic

配置OSPF

//相当于这台机器身份的标识,整个局域网必须唯一,可以不写router-id,系统会随机分配id编号,为了方便区分,所以最好写上。
[H3C]router id 1.1.1.1
//进程号为10
[H3C]ospf 10
//区域为0
[H3C-ospf-1]area 0
[H3C-ospf-1-area-0.0.0.0]network 1.1.1.1 0.0.0.0  # 要发布的路由

更多关于ospf的详细解释参考:网络设备配置管理实例

关于route模式和bridge模式

[H3C] interface g1/0/1
[H3C-GigabitEthernet1/0/1] port link-mode route //开启该接口的三层路由功能
[H3C-GigabitEthernet1/0/1] port link-mode bridge //关闭该接口的三层路由功能
  1. 如果交换机的端口支持路由模式,可直接设置IP地址

    int gi 1/0/1 
    port link-mode route
    ip address 192.168.1.1 24
    quit
  2. 如果交换机的端口不支持路由模式,只能通过VLAN的方式将接口划分到VLAN,并配置IP地址

    vlan 10
    quit
    int vlan 10
    ip address 192.168.1.1 24
    quit
    int gi 1/0/1
    port access vlan 10
    quit

参考自:华三交换机的用户模式 特权模式 全局配置模式 端口模式 ,用什么命令进入?端口模式设定一个ip如何设置? - 知了社区。能直接给vlan10添加ip,不是要先创建虚接口吗,不懂?

常见命令

命令和思科一样,区分大小写不我没试,但是命令可以缩写都是一样的,比如 display current-configuration 也可以简化dis cur 即可。

? //查看命令帮助
system-view //进入特权模式
save //保存配置
reset save //还原配置
reboot //重启
interface GigabitEthernet 1/0/1 //进入1/0/1端口视图

display vlan 100 //查看vlan 100,和display current-configuration vlan 100 的区别不知道
display vlan all //查看所有的vlan

display current-configuration //应该是显示当前路由器的配置,简写为display cur
display history-command //貌似是显示历史命令,没试过

display current-configuration vlan 1 //查看vlan 1的配置信息,没试过,瞎几儿蒙的

display current-configuration interface //查看所有端口的详细信息

display current-configuration interface g1/0/1 //查看g1/0/1端口的详细信息
display interface g1/0/1 //不知道有什么区别
display brief interface  g1/0/1 //不知道有什么区别

display alarm all // 查看警报信息

display interface brief // 简要查看虚拟接口的信息
display interface // 详细查看虚拟接口的信息

display ip interface brief  // 查看虚拟接口的ip

display port trunk //查看设备上开启trunk的端口,PVID

display ip routing-table //查看路由表
display ip routing-table verbose //查看路由表的详细信息
display ip routing-table statistics //查看路由表里各协议的路由统计信息
reset ip routing-table statistics protocol all //清除路由表里各协议的路由统计信息
display ip routing-table protocol static //显示静态路由表


quit //退出当前视图模式


1、system-view 进入系统视图模式
2、sysname H3C 将设备重命名为"H3C"
3、quit 退出当前视图模式
4、 language-mode Chinese|English 中英文切换
5、interface Ethernet 1/0/1 进入以太网端口视图
6、 port link-type Access|Trunk|Hybrid 设置端口访问模式
7、 undo shutdown 打开以太网端口
8、 shutdown 关闭以太网端口
9、 vlan 10 创建VLAN 10并进入VLAN 10的视图模式
10、 port access vlan 10 在端口模式下将当前端口加入到vlan 10中
11、port E1/0/2 to E1/0/5 在VLAN模式下将指定端口加入到当前vlan中
12、port trunk permit vlan all 允许所有的vlan通过

快速查找命令含义

直接谷歌搜索 "命令 h3c.com",然后选择 简体网页 即可。